Back to overview
Downtime
Backup issues
Oct 16, 2023 at 04:00am UTC
Resolved
Oct 31, 2023 at 05:00am UTC
Backup fixed
Affected services
Created
Oct 16, 2023 at 04:00am UTC
Persisting issues while backup up data
Affected services