Back to overview
Downtime

All webservices offline

May 30, 2025 at 01:02pm UTC
Affected services
Alpha
Dashboard
Search
Media Server
Ombi
Media Accounts
immich Gallery
Stirling PDF Tools
Analytics

Resolved
May 30, 2025 at 07:31pm UTC

All services back online

Updated
May 30, 2025 at 07:15pm UTC

Server restarted. Most services should be back online now or soon.

Created
May 30, 2025 at 01:02pm UTC

Alpha crashed yet again...